I'm in the process of developing a responsive theme that I plan to offer for sale. It's important to me that users can easily understand what the theme offers at first glance. One challenge I have encountered when transitioning from Foundation 3 to Bootstrap 3 and Foundation 4 is the need for longer, more descriptive class names to accommodate various screen sizes.
As a result, I've made an effort to create something like this:
<a class="button soluks_button square_round no_bold">Button</a>
OR This
<a class="custom-button green square-round button-in-navbar text-shadow">Button</a>
Since I am basing my styles on Bootstrap and Foundation, I wonder if these class names are too complex. Would it be better to simplify or is it okay as long as they remain readable?